summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-15 16:51:01 -0400
committerLeo Famulari <leo@famulari.name>2017-05-15 17:07:12 -0400
commit5e54f4adda6b636b03b252804565f4d845d03658 (patch)
treefc0bbd7d618820f670125052eb038235b8ca7504 /gnu/packages/flex.scm
parent93fabf59962aeb15981bd547850de1dab69eccfb (diff)
downloadguix-patches-5e54f4adda6b636b03b252804565f4d845d03658.tar
guix-patches-5e54f4adda6b636b03b252804565f4d845d03658.tar.gz
gnu: flex-2.6.1: Remove variable.
* gnu/packages/flex.scm (flex-2.6.1): Remove variable. * gnu/packages/bootloaders.scm (grub, dtc): Use flex instead of flex-2.6.1. * gnu/packages/embedded.scm (propeller-binutils, binutils-vc4): Likewise. * gnu/packages/maths.scm (scotch): Likewise. * gnu/packages/wine.scm (wine): Likewise.
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index ab0d8c583d..b68b01e949 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -85,20 +85,3 @@ regular expressions for each rule. Whenever it finds a match, it
executes the corresponding C code.")
(license (non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
-
-;;; Many packages fail to build with flex > 2.6.1, due to this bug in flex:
-;;; <https://github.com/westes/flex/issues/162>
-;;; We must not use a flex before 2.6.1, due to CVE-2016-6354.
-;;; TODO Try using flex > 2.6.3.
-(define-public flex-2.6.1
- (package
- (inherit flex)
- (version "2.6.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/westes/flex"
- "/releases/download/v" version "/"
- "flex-" version ".tar.xz"))
- (sha256
- (base32
- "0gqhk4vkwy4gl9xbpgkljph8c0a5kpijz6wd0p5r9q202qn42yic"))))))