summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-15 16:51:01 -0400
committerLeo Famulari <leo@famulari.name>2017-05-15 17:07:12 -0400
commit5e54f4adda6b636b03b252804565f4d845d03658 (patch)
treefc0bbd7d618820f670125052eb038235b8ca7504
parent93fabf59962aeb15981bd547850de1dab69eccfb (diff)
downloadguix-patches-5e54f4adda6b636b03b252804565f4d845d03658.tar
guix-patches-5e54f4adda6b636b03b252804565f4d845d03658.tar.gz
gnu: flex-2.6.1: Remove variable.
* gnu/packages/flex.scm (flex-2.6.1): Remove variable. * gnu/packages/bootloaders.scm (grub, dtc): Use flex instead of flex-2.6.1. * gnu/packages/embedded.scm (propeller-binutils, binutils-vc4): Likewise. * gnu/packages/maths.scm (scotch): Likewise. * gnu/packages/wine.scm (wine): Likewise.
-rw-r--r--gnu/packages/bootloaders.scm7
-rw-r--r--gnu/packages/embedded.scm4
-rw-r--r--gnu/packages/flex.scm17
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/wine.scm3
5 files changed, 6 insertions, 27 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 98afc6a7c1..572186bea7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -114,10 +114,7 @@
(native-inputs
`(("unifont" ,unifont)
("bison" ,bison)
- ;; Due to a bug in flex >= 2.6.2, GRUB must be built with an older flex:
- ;; <http://lists.gnu.org/archive/html/grub-devel/2017-02/msg00133.html>
- ;; TODO Try building with flex > 2.6.3.
- ("flex" ,flex-2.6.1)
+ ("flex" ,flex)
("texinfo" ,texinfo)
("help2man" ,help2man)
@@ -240,7 +237,7 @@ menu to select one of the installed operating systems.")
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
- ("flex" ,flex-2.6.1))) ; A bug in flex prevents building with flex-2.6.3.
+ ("flex" ,flex)))
(arguments
`(#:make-flags
(list "CC=gcc"
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf2..fbbafc6a3b 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -412,7 +412,7 @@ with a layered architecture of JTAG interface and TAP support.")
,@(package-arguments xbinutils)))
(native-inputs
`(("bison" ,bison)
- ("flex" ,flex-2.6.1) ; needed because of yywrap error
+ ("flex" ,flex)
("texinfo" ,texinfo)
("dejagnu" ,dejagnu)
,@(package-native-inputs xbinutils))))))
@@ -764,7 +764,7 @@ simulator.")
(base32
"14b3h2ji740s8zq5vwm4qdcxs4aa4wxi6wb9di3bv1h39x14nyr9"))))
("texinfo" ,texinfo)
- ("flex" ,flex-2.6.1) ; A bug in flex prevents building with flex-2.6.3.
+ ("flex" ,flex)
("bison" ,bison)
("guile-1.8" ,guile-1.8)
("which" ,base:which)))
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index ab0d8c583d..b68b01e949 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -85,20 +85,3 @@ regular expressions for each rule. Whenever it finds a match, it
executes the corresponding C code.")
(license (non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
-
-;;; Many packages fail to build with flex > 2.6.1, due to this bug in flex:
-;;; <https://github.com/westes/flex/issues/162>
-;;; We must not use a flex before 2.6.1, due to CVE-2016-6354.
-;;; TODO Try using flex > 2.6.3.
-(define-public flex-2.6.1
- (package
- (inherit flex)
- (version "2.6.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/westes/flex"
- "/releases/download/v" version "/"
- "flex-" version ".tar.xz"))
- (sha256
- (base32
- "0gqhk4vkwy4gl9xbpgkljph8c0a5kpijz6wd0p5r9q202qn42yic"))))))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cefc53d67d..a4505c7b6f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1807,7 +1807,7 @@ implemented in ANSI C, and MPI for communications.")
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
- ("flex" ,flex-2.6.1) ; A bug in flex prevents building with flex-2.6.3.
+ ("flex" ,flex)
("bison" ,bison)))
(arguments
`(#:phases
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 9c82e01d67..a74cbcf2b4 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -65,8 +65,7 @@
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
- ; A bug in flex prevents building with flex-2.6.3.
- ("flex" ,flex-2.6.1)
+ ("flex" ,flex)
("bison" ,bison)
("perl" ,perl)))
(inputs