summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-28 09:49:38 -0400
committerLeo Famulari <leo@famulari.name>2017-05-28 09:56:14 -0400
commit2dca204eb02835504df6846d9a543c729dc612e4 (patch)
tree7e87f83eb0f1ea61546f1df877348a454ca11ab1 /gnu/packages/flex.scm
parent77e2538eda8a2721aef8336103c94fe31e12870c (diff)
downloadguix-patches-2dca204eb02835504df6846d9a543c729dc612e4.tar
guix-patches-2dca204eb02835504df6846d9a543c729dc612e4.tar.gz
gnu: flex: Use the gzip-compressed tarball.
This reverts commit 77e2538eda8a2721aef8336103c94fe31e12870c and fetches the gzip-compressed tarball. We do this so that flex-boot0 will not require lzip. * gnu/packages/flex.scm (flex)[source]: Fetch the '.tar.gz' tarball. [native-inputs]: Remove lzip.
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 70707d77d4..fdda5f365d 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -23,7 +23,6 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages compression)
#:use-module (gnu packages m4)
#:use-module (gnu packages man)
#:use-module (gnu packages bison)
@@ -39,10 +38,10 @@
(uri (string-append
"https://github.com/westes/flex"
"/releases/download/v" version "/"
- "flex-" version ".tar.lz"))
+ "flex-" version ".tar.gz"))
(sha256
(base32
- "19sc63m09zamy2qlw5x3sg6wb6hrw96gfl0h87vh6flvsqjg9m3g"))))
+ "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
(build-system gnu-build-system)
(inputs
(let ((bison-for-tests
@@ -68,7 +67,6 @@
;; m4 is not present in PATH when cross-building
(native-inputs
`(("help2man" ,help2man)
- ("lzip" ,lzip)
("m4" ,m4)))
(propagated-inputs `(("m4" ,m4)))
(home-page "https://github.com/westes/flex")