summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-09 02:52:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-09 04:27:33 +0200
commit478104c398840d8fa9415d1250d4501b2280d2f3 (patch)
treeb3f88d8dcbd2acc65a638d244ab5007e61bfabce /gnu/packages/file-systems.scm
parent5f071925ef26493582ee78a6a37d6a8e2d033bc4 (diff)
downloadguix-patches-478104c398840d8fa9415d1250d4501b2280d2f3.tar
guix-patches-478104c398840d8fa9415d1250d4501b2280d2f3.tar.gz
gnu: mergerfs: Do not refer to the native bash.
* gnu/packages/linux.scm (mergerfs)[inputs]: Add bash-minimal. [arguments]: Refer to it rather than to the native build bash.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c6773cc20a..2332258928 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1404,8 +1405,8 @@ On Guix System, you will need to invoke the included shell scripts as
(string-append (assoc-ref inputs "util-linux")
"/bin/" maybe-u "mount")))
(substitute* '("libfuse/util/mount.mergerfs.c")
- (("/bin/sh")
- (which "sh")))
+ (("/bin/sh" command)
+ (string-append (assoc-ref inputs "bash-minimal") command)))
;; The Makefile does not allow overriding PREFIX via make variables.
(substitute* '("Makefile" "libfuse/Makefile")
(("= /usr/local") (string-append "= " (assoc-ref outputs "out")))
@@ -1416,7 +1417,9 @@ On Guix System, you will need to invoke the included shell scripts as
(("strip") "true"))
#t)))))
;; mergerfs bundles a heavily modified copy of libfuse.
- (inputs `(("util-linux" ,util-linux)))
+ (inputs
+ `(("bash-minimal" ,bash-minimal)
+ ("util-linux" ,util-linux)))
(home-page "https://github.com/trapexit/mergerfs")
(synopsis "Featureful union file system")
(description "mergerfs is a union file system geared towards simplifying