summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-09 02:48:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-09 04:26:45 +0200
commit5f071925ef26493582ee78a6a37d6a8e2d033bc4 (patch)
treee3c0b192976a2c81bad2906af486dae048171a7a /gnu/packages/file-systems.scm
parent73a2edf25b9ba27c7762b9dd9f42cd867029dad5 (diff)
downloadguix-patches-5f071925ef26493582ee78a6a37d6a8e2d033bc4.tar
guix-patches-5f071925ef26493582ee78a6a37d6a8e2d033bc4.tar.gz
gnu: mergerfs: Cross-compile.
* gnu/packages/file-systems.scm (mergerfs)[arguments]: Use CC-FOR-TARGET and CXX-FOR-TARGET. Don't let the Makefile strip binaries.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c3eacea9c6..c6773cc20a 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1388,7 +1388,10 @@ On Guix System, you will need to invoke the included shell scripts as
(base32 "08gwi094ll0b7nf2i44fyjxiyvr45rp766npbdyw0yzyigas8a2f"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests exist.
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "CXX=" ,(cxx-for-target)))
+ #:tests? #f ; No tests exist.
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -1408,7 +1411,9 @@ On Guix System, you will need to invoke the included shell scripts as
(("= /usr/local") (string-append "= " (assoc-ref outputs "out")))
(("= /sbin") "= $(EXEC_PREFIX)/sbin")
;; cannot chown as build user
- (("chown root(:root)?") "true"))
+ (("chown root(:root)?") "true")
+ ;; Breaks cross-compilation.
+ (("strip") "true"))
#t)))))
;; mergerfs bundles a heavily modified copy of libfuse.
(inputs `(("util-linux" ,util-linux)))