summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 22:57:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commitf9bd633798bd572f60d52211d27a601cd0874f2b (patch)
tree657ba692bc4b7567b343eac9dd437399f8746baf /gnu/packages/erlang.scm
parent8c40443a15622a377ea6dd90f18c7834d405f321 (diff)
downloadguix-patches-f9bd633798bd572f60d52211d27a601cd0874f2b.tar
guix-patches-f9bd633798bd572f60d52211d27a601cd0874f2b.tar.gz
gnu: Add erlang-bbmustache.
* gnu/packages/erlang.scm (erlang-bbmustache): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index bbd63518f1..f230bb02c5 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -225,6 +225,40 @@ built-in support for concurrency, distribution and fault tolerance.")
files.")
(license license:asl2.0)))
+(define-public erlang-bbmustache
+ (package
+ (name "erlang-bbmustache")
+ (version "1.12.1")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "bbmustache" version))
+ (sha256
+ (base32 "0wbfayx6940zf57bpwg1m9sk3cpgam2q8n0w74alkrc4gc7hn47w"))))
+ (build-system rebar3-build-system)
+ (inputs
+ `(("erlang-edown" ,erlang-edown)
+ ("erlang-getopt" ,erlang-getopt)
+ ("erlang-rebar3-git-vsn" ,erlang-rebar3-git-vsn)))
+ (arguments
+ `(#:tests? #f ;; requires mustache specification file
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'build-escript
+ (lambda _
+ (invoke "rebar3" "as" "dev" "escriptize")))
+ (add-after 'install 'install-escript
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (install-file "_build/dev/bin/bbmustache"
+ (string-append out "/bin")))
+ #t)))))
+ (home-page "https://github.com/soranoba/bbmustache/")
+ (synopsis "Binary pattern match Based Mustache template engine for Erlang")
+ (description "This Erlang library provides a Binary pattern match Based
+Mustache template engine")
+ (license license:expat)))
+
(define-public erlang-certifi
(package
(name "erlang-certifi")