summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:18:32 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commit8c40443a15622a377ea6dd90f18c7834d405f321 (patch)
treef92fea8bcfbf54ceab2dff0583373ff5fda309f3 /gnu/packages/erlang.scm
parent29666a1b92d08afd0986772f7b8b0d031219bf18 (diff)
downloadguix-patches-8c40443a15622a377ea6dd90f18c7834d405f321.tar
guix-patches-8c40443a15622a377ea6dd90f18c7834d405f321.tar.gz
gnu: Add erlang-cth-readable.
* gnu/packages/erlang.scm (erlang-cth-readable): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 8e91655fbb..bbd63518f1 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -266,6 +266,27 @@ Mozilla's canonical set.")
printing extending the io:format syntax to add colours.")
(license license:expat)))
+(define-public erlang-cth-readable
+ (package
+ (name "erlang-cth-readable")
+ (version "1.5.1")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "cth_readable" version))
+ (sha256
+ (base32 "0hqzgd8fvs4d1bhpm6dkm3bm2jik4qbl78s514r5ivwjxw1dzrds"))))
+ (build-system rebar3-build-system)
+ (propagated-inputs
+ `(("erlang-cf" ,erlang-cf)))
+ (arguments
+ `(#:tests? #f)) ;; no test-suite
+ (home-page "https://github.com/ferd/cth_readable")
+ (synopsis "Common Test hooks for more readable logs for Erlang")
+ (description "This package provides an OTP library to be used for CT log
+outputs you want to be readable around all that noise they contain.")
+ (license license:bsd-3)))
+
(define-public erlang-erlware-commons
(package
(name "erlang-erlware-commons")