summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 22:02:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commit29666a1b92d08afd0986772f7b8b0d031219bf18 (patch)
treefbc438f4c1ef41f0b1a36980089df7d4822f04e4 /gnu/packages/erlang.scm
parent8184d7679ad17f825f0cd1ea5142b4a5d767a3ce (diff)
downloadguix-patches-29666a1b92d08afd0986772f7b8b0d031219bf18.tar
guix-patches-29666a1b92d08afd0986772f7b8b0d031219bf18.tar.gz
gnu: Add erlang-erlware-commons.
* gnu/packages/erlang.scm (erlang-erlware-commons): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 320b89e8f2..8e91655fbb 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -265,3 +265,26 @@ Mozilla's canonical set.")
(description "This package provides a helper library for termial colour
printing extending the io:format syntax to add colours.")
(license license:expat)))
+
+(define-public erlang-erlware-commons
+ (package
+ (name "erlang-erlware-commons")
+ (version "1.6.0")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "erlware_commons" version))
+ (sha256
+ (base32 "0xc3kiylingqrrnzhxm2j2n5gr3hxqgpibhi9nva9bwjs4n155fm"))))
+ (build-system rebar3-build-system)
+ (propagated-inputs
+ `(("erlang-cf" ,erlang-cf)))
+ (native-inputs
+ `(("git" ,git))) ;; Required for tests
+ (arguments
+ `(#:tests? #f)) ;; TODO: 1/219 tests fail - very simple one, though
+ (home-page "http://erlware.github.io/erlware_commons/")
+ (synopsis "Additional standard library for Erlang")
+ (description "Erlware Commons is an Erlware project focused on all aspects
+of reusable Erlang components.")
+ (license license:expat)))