summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 18:31:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commit0402da848b60bfd4f1c66768122208739f9cfa6d (patch)
tree35aa187872ff3e055afa85c241682b23d00f9a39 /gnu/packages/erlang.scm
parent7f039171e945351b2ff9a6d276be764248a4416a (diff)
downloadguix-patches-0402da848b60bfd4f1c66768122208739f9cfa6d.tar
guix-patches-0402da848b60bfd4f1c66768122208739f9cfa6d.tar.gz
gnu: Add erlang-rebar3-git-vsn.
* gnu/packages/erlang.scm (erlang-rebar3-git-vsn): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 6003bec251..9255edebbe 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages tls)
#:use-module (gnu packages wxwidgets))
@@ -511,6 +512,37 @@ testing of stateful systems.")
(description "This package provides an Erlang providers library.")
(license license:asl2.0)))
+(define-public erlang-rebar3-git-vsn
+ (package
+ (name "erlang-rebar3-git-vsn")
+ (version "1.1.1")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "rebar3_git_vsn" version))
+ (sha256
+ (base32 "1ra4xjyc40r97aqb8aq2rll1v8wkf9jyisnbk34xdqcgv9s9iw7d"))))
+ (build-system rebar3-build-system)
+ (inputs
+ `(("git" ,git)))
+ (arguments
+ `(;; Running the tests require binary artifact (tar-file containing
+ ;; samples git repos)
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((git (assoc-ref inputs "git")))
+ (substitute* "src/rebar3_git_vsn.erl"
+ (("rebar_utils:sh\\(\"git " _)
+ (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
+ (home-page "https://github.com/soranoba/rebar3_git_vsn")
+ (synopsis "Rebar3 plugin for generating the version from git")
+ (description "This plugin adds support for generating the version from
+a git checkout.")
+ (license license:expat)))
+
(define-public erlang-rebar3-raw-deps
(package
(name "erlang-rebar3-raw-deps")