summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 16:01:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commit7f039171e945351b2ff9a6d276be764248a4416a (patch)
treefc33fba3386953d944780ae2db6b7fb8c806380e /gnu/packages/erlang.scm
parentd37baa4bcff493510322f3ebb88410cafe94daea (diff)
downloadguix-patches-7f039171e945351b2ff9a6d276be764248a4416a.tar
guix-patches-7f039171e945351b2ff9a6d276be764248a4416a.tar.gz
gnu: Add erlang-rebar3-raw-deps.
* gnu/packages/erlang.scm (erlang-rebar3-raw-deps): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 3c6ee9038a..6003bec251 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -511,6 +511,23 @@ testing of stateful systems.")
(description "This package provides an Erlang providers library.")
(license license:asl2.0)))
+(define-public erlang-rebar3-raw-deps
+ (package
+ (name "erlang-rebar3-raw-deps")
+ (version "2.0.0")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "rebar3_raw_deps" version))
+ (sha256
+ (base32 "1w8whb86yl2mpv67biqnwaam8xpm4pq8yyidifzj1svjyd37hxv7"))))
+ (build-system rebar3-build-system)
+ (home-page "https://github.com/soranoba/rebar3_raw_deps")
+ (synopsis "Rebar3 plugin for supporting \"raw\" dependencies")
+ (description "This plugin adds support for \"raw\" dependencies to
+rebar3.")
+ (license license:expat)))
+
(define-public erlang-relx
(package
(name "erlang-relx")