summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 02:56:51 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 03:01:41 +0100
commit3505d86502c80fa390d2c6db103697307d596b0e (patch)
tree03213c8855f513b760062e51f95a87450ff9e27c /gnu/packages/engineering.scm
parent3d5c5cf611cc09c03e9d641094d86e3afc96d6c6 (diff)
downloadguix-patches-3505d86502c80fa390d2c6db103697307d596b0e.tar
guix-patches-3505d86502c80fa390d2c6db103697307d596b0e.tar.gz
gnu: openscad: Update to 2021.01 [maybe fixes TALOS-2020-1222, TALOS-2020-1223].
TALOS-2020-1222 has yet to be disclosed and has no known CVE number. TALOS-2020-1223 has CVE-2020-28599 assigned. * gnu/packages/engineering.scm (openscad): Update to 2021.01. [patches]: Remove. Boost 1.72 is supported now upstream. [arguments]: In replacement 'check phase, disable some tests requiring experimental "lazy-union" feature. Also disable PDF-related tests requiring ghostscript and failing either way. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/openscad-parser-boost-1.72.patch: Ditto.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index fb6895f911..8517d2abde 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2476,7 +2476,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(define-public openscad
(package
(name "openscad")
- (version "2019.05")
+ (version "2021.01")
(source
(origin
(method url-fetch)
@@ -2484,9 +2484,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
".src.tar.gz"))
(sha256
(base32
- "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))
- (patches (search-patches
- "openscad-parser-boost-1.72.patch"))))
+ "0n83szr88h8snccjrslr96mgw3f65x3sq726n6x5vxp5wybw4f6r"))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost)
@@ -2529,7 +2527,17 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(with-directory-excursion "tests"
(invoke "cmake" ".")
(invoke "make")
- (invoke "ctest"))
+ (invoke "ctest" "--exclude-regex"
+ (string-join
+ (list
+ "astdumptest_allexpressions"
+ "echotest_function-literal-compare"
+ "echotest_function-literal-tests"
+ "echotest_allexpressions"
+ "lazyunion-*"
+ "pdfexporttest_centered"
+ "pdfexporttest_simple-pdf")
+ "|")))
;; strip python test files since lib dir ends up in out/share
(for-each delete-file
(find-files "libraries/MCAD" ".*\\.py"))