summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 02:56:51 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 03:01:41 +0100
commit3505d86502c80fa390d2c6db103697307d596b0e (patch)
tree03213c8855f513b760062e51f95a87450ff9e27c /gnu/packages
parent3d5c5cf611cc09c03e9d641094d86e3afc96d6c6 (diff)
downloadguix-patches-3505d86502c80fa390d2c6db103697307d596b0e.tar
guix-patches-3505d86502c80fa390d2c6db103697307d596b0e.tar.gz
gnu: openscad: Update to 2021.01 [maybe fixes TALOS-2020-1222, TALOS-2020-1223].
TALOS-2020-1222 has yet to be disclosed and has no known CVE number. TALOS-2020-1223 has CVE-2020-28599 assigned. * gnu/packages/engineering.scm (openscad): Update to 2021.01. [patches]: Remove. Boost 1.72 is supported now upstream. [arguments]: In replacement 'check phase, disable some tests requiring experimental "lazy-union" feature. Also disable PDF-related tests requiring ghostscript and failing either way. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/openscad-parser-boost-1.72.patch: Ditto.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm18
-rw-r--r--gnu/packages/patches/openscad-parser-boost-1.72.patch26
2 files changed, 13 insertions, 31 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index fb6895f911..8517d2abde 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2476,7 +2476,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(define-public openscad
(package
(name "openscad")
- (version "2019.05")
+ (version "2021.01")
(source
(origin
(method url-fetch)
@@ -2484,9 +2484,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
".src.tar.gz"))
(sha256
(base32
- "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))
- (patches (search-patches
- "openscad-parser-boost-1.72.patch"))))
+ "0n83szr88h8snccjrslr96mgw3f65x3sq726n6x5vxp5wybw4f6r"))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost)
@@ -2529,7 +2527,17 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(with-directory-excursion "tests"
(invoke "cmake" ".")
(invoke "make")
- (invoke "ctest"))
+ (invoke "ctest" "--exclude-regex"
+ (string-join
+ (list
+ "astdumptest_allexpressions"
+ "echotest_function-literal-compare"
+ "echotest_function-literal-tests"
+ "echotest_allexpressions"
+ "lazyunion-*"
+ "pdfexporttest_centered"
+ "pdfexporttest_simple-pdf")
+ "|")))
;; strip python test files since lib dir ends up in out/share
(for-each delete-file
(find-files "libraries/MCAD" ".*\\.py"))
diff --git a/gnu/packages/patches/openscad-parser-boost-1.72.patch b/gnu/packages/patches/openscad-parser-boost-1.72.patch
deleted file mode 100644
index 35311e6173..0000000000
--- a/gnu/packages/patches/openscad-parser-boost-1.72.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://github.com/openscad/openscad/commit/b6c170cc5d.patch
-
-From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
-From: Jan Beich <jbeich@FreeBSD.org>
-Date: Fri, 25 Oct 2019 15:10:26 +0000
-Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
-
-src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
-std::stack<LocalScope *> scope_stack;
-~~~~~^
----
- src/parser.y | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/parser.y b/src/parser.y
-index 7f4fd56ca7..4c77c989ea 100644
---- a/src/parser.y
-+++ b/src/parser.y
-@@ -46,6 +46,7 @@
- #include "printutils.h"
- #include "memory.h"
- #include <sstream>
-+#include <stack>
- #include <boost/filesystem.hpp>
- #include "boost-utils.h"
- #include "feature.h"