summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-05-18 15:55:12 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2021-05-18 15:55:12 +0200
commitb72e27c84284acff043c3a04dc43ce72fc840ca8 (patch)
treeaccc6b2c2623b947cb3fc9a392167b61bfff37ee /gnu/packages/embedded.scm
parent4d69bd76961b5f9768a42861e0ad78ffeb2e8b83 (diff)
downloadguix-patches-b72e27c84284acff043c3a04dc43ce72fc840ca8.tar
guix-patches-b72e27c84284acff043c3a04dc43ce72fc840ca8.tar.gz
gnu: fc-host-tools: Make installation path patcher more self-maintaining.
* gnu/packages/embedded.scm (fc-host-tools)[arguments]<#:phases> [patch-installation-paths]: Make phase more self-maintaining.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index b2dab9ce26..8109ec24a1 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1237,21 +1237,9 @@ SPI, I2C, JTAG.")
(modify-phases %standard-phases
(add-after 'unpack 'patch-installation-paths
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* '("Makefile"
- "rvinterf/etmsync/fsiomain.c"
- "rvinterf/etmsync/fsnew.c"
- "rvinterf/asyncshell/help.c"
- "rvinterf/libinterf/launchrvif.c"
- "loadtools/bpmain.c"
- "loadtools/defpath.c"
- "loadtools/romdump.c"
- "loadtools/lthelp.c"
- "loadtools/simmain.c"
- "loadtools/Makefile"
- "miscutil/c139explore"
- "miscutil/pirexplore"
- "ffstools/tiffs-wrappers/installpath.c"
- "uptools/atcmd/atinterf.c")
+ (substitute* (cons* "miscutil/c139explore"
+ "miscutil/pirexplore"
+ (find-files "." "^(.*\\.[ch]|Makefile)$"))
(("/opt/freecalypso/bin/fc-simtool")
"fc-simtool")
(("/opt/freecalypso/bin/fc-uicc-tool")