summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-05-18 15:49:41 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2021-05-18 15:50:52 +0200
commit4d69bd76961b5f9768a42861e0ad78ffeb2e8b83 (patch)
treeb9ba9c4ae9be59b261f8237569ff9597790fc53a /gnu/packages/embedded.scm
parentb905abfbd3235322c826e3b0ad45e410a3cd96f3 (diff)
downloadguix-patches-4d69bd76961b5f9768a42861e0ad78ffeb2e8b83.tar
guix-patches-4d69bd76961b5f9768a42861e0ad78ffeb2e8b83.tar.gz
gnu: fc-host-tools: Update to 15.
* gnu/packages/embedded.scm (fc-host-tools): Update to 15. [description]: Add fc-simint. [arguments]<#:phases>[patch-installation-paths]: Add files.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 901afba29b..b2dab9ce26 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1219,14 +1219,14 @@ SPI, I2C, JTAG.")
(define-public fc-host-tools
(package
(name "fc-host-tools")
- (version "14")
+ (version "15")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.freecalypso.org/pub/GSM/"
"FreeCalypso/fc-host-tools-r" version ".tar.bz2"))
(sha256
(base32
- "09ccd76khfvlx4dwi9dhrzl5mm68402mlych0g7f9ncfr5jzyf26"))))
+ "17v3xc44mmlvp0irwm1p55zdgzd31ic3nsjxnv8y28a1i85103cv"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests exist.
@@ -1242,12 +1242,20 @@ SPI, I2C, JTAG.")
"rvinterf/etmsync/fsnew.c"
"rvinterf/asyncshell/help.c"
"rvinterf/libinterf/launchrvif.c"
+ "loadtools/bpmain.c"
"loadtools/defpath.c"
+ "loadtools/romdump.c"
+ "loadtools/lthelp.c"
+ "loadtools/simmain.c"
"loadtools/Makefile"
"miscutil/c139explore"
"miscutil/pirexplore"
"ffstools/tiffs-wrappers/installpath.c"
"uptools/atcmd/atinterf.c")
+ (("/opt/freecalypso/bin/fc-simtool")
+ "fc-simtool")
+ (("/opt/freecalypso/bin/fc-uicc-tool")
+ "fc-uicc-tool")
(("/opt/freecalypso/loadtools")
(string-append (assoc-ref outputs "out") "/lib/freecalypso/loadtools"))
(("\\$\\{INSTALL_PREFIX\\}/loadtools")
@@ -1301,6 +1309,9 @@ to flash storage.
@item fc-iram: Allows running programs on the device without writing them
to flash storage.
@item fc-loadtool: Writes programs to the device's flash storage.
+@item fc-simint: Loads and runs simagent on the phone, then calls fc-simtool
+(see @url{https://www.freecalypso.org/hg/fc-sim-tools,fc-sim-tools
+repository}) on the host to connect to it.
@item pirffs: Allows listing and extracting FFS content captured as a raw
flash image from Pirelli phones.
@item mokoffs: Allows listing and extracting FFS content captured as a raw