summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-19 21:33:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-03-19 21:48:03 +0200
commitc24f1f1614a2ba7ff7c5828a8753f82c9792349a (patch)
treeea8cb69ac6d6aea4ab58f4831e820d0375dda20b /gnu/packages/elf.scm
parent4eade64706d88434fb6096e2b9506e2022e3137b (diff)
downloadguix-patches-c24f1f1614a2ba7ff7c5828a8753f82c9792349a.tar
guix-patches-c24f1f1614a2ba7ff7c5828a8753f82c9792349a.tar.gz
gnu: patchelf: Use 'target-arm32?' for armhf-linux case.
* gnu/packages/elf.scm (patchelf)[inputs]: Replace armhf-linux detection logic with 'target-arm32?' macro. [arguments]: Same.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 8fb568b841..8329637da3 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -22,6 +22,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages elf)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -121,12 +122,12 @@ Executable and Linkable Format (@dfn{ELF}). This includes @command{ld},
;; patch makes significant changes to the algorithm, possibly
;; introducing bugs. So, we apply the patch only on ARM systems.
(inputs
- (if (string-prefix? "arm" (or (%current-target-system) (%current-system)))
+ (if (target-arm32?)
`(("patch/rework-for-arm" ,(search-patch
"patchelf-rework-for-arm.patch")))
'()))
(arguments
- (if (string-prefix? "arm" (or (%current-target-system) (%current-system)))
+ (if (target-arm32?)
`(#:phases (alist-cons-after
'unpack 'patch/rework-for-arm
(lambda* (#:key inputs #:allow-other-keys)