summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/elf.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 8fb568b841..8329637da3 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -22,6 +22,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages elf)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -121,12 +122,12 @@ Executable and Linkable Format (@dfn{ELF}). This includes @command{ld},
;; patch makes significant changes to the algorithm, possibly
;; introducing bugs. So, we apply the patch only on ARM systems.
(inputs
- (if (string-prefix? "arm" (or (%current-target-system) (%current-system)))
+ (if (target-arm32?)
`(("patch/rework-for-arm" ,(search-patch
"patchelf-rework-for-arm.patch")))
'()))
(arguments
- (if (string-prefix? "arm" (or (%current-target-system) (%current-system)))
+ (if (target-arm32?)
`(#:phases (alist-cons-after
'unpack 'patch/rework-for-arm
(lambda* (#:key inputs #:allow-other-keys)