summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 06:08:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 06:08:33 +0200
commite41ddf7605922b3a30d4cc37fe700068d6ee0d70 (patch)
tree2c797daa16e60e7097328e91060c7d9364c61530 /gnu/packages/dns.scm
parenta8f52ad7c1c6fdb33a97989ae546119c256a662b (diff)
downloadguix-patches-e41ddf7605922b3a30d4cc37fe700068d6ee0d70.tar
guix-patches-e41ddf7605922b3a30d4cc37fe700068d6ee0d70.tar.gz
gnu: knot: Update to 2.8.1.
* gnu/packages/dns.scm (knot): Update to 2.8.1. [source]: Remove patch. * gnu/packages/patches/knot-include-system-lmdb-header.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 461d9f8c0c..9cffe3b822 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -569,23 +569,21 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "2.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://secure.nic.cz/files/knot-dns/"
- "knot-" version ".tar.xz"))
- (sha256
- (base32
- "1vw7xx7bm440jwrpvdd04vrp6ccz2b11swcn9msvs62hf0kdjjj9"))
- (patches
- (search-patches "knot-include-system-lmdb-header.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (with-directory-excursion "src/contrib"
- (delete-file-recursively "lmdb"))
- #t))))
+ (version "2.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://secure.nic.cz/files/knot-dns/"
+ "knot-" version ".tar.xz"))
+ (sha256
+ (base32 "1im2wb8hl394mzni1wavmvfqd7il8s28kcz8w3s4v05nbhzg06xj"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libraries.
+ (with-directory-excursion "src/contrib"
+ (delete-file-recursively "lmdb"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))