summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 06:08:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 06:08:33 +0200
commite41ddf7605922b3a30d4cc37fe700068d6ee0d70 (patch)
tree2c797daa16e60e7097328e91060c7d9364c61530 /gnu
parenta8f52ad7c1c6fdb33a97989ae546119c256a662b (diff)
downloadguix-patches-e41ddf7605922b3a30d4cc37fe700068d6ee0d70.tar
guix-patches-e41ddf7605922b3a30d4cc37fe700068d6ee0d70.tar.gz
gnu: knot: Update to 2.8.1.
* gnu/packages/dns.scm (knot): Update to 2.8.1. [source]: Remove patch. * gnu/packages/patches/knot-include-system-lmdb-header.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/dns.scm32
-rw-r--r--gnu/packages/patches/knot-include-system-lmdb-header.patch34
3 files changed, 15 insertions, 52 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 850444dfd4..70ad61af5b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -949,7 +949,6 @@ dist_patch_DATA = \
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
- %D%/packages/patches/knot-include-system-lmdb-header.patch \
%D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 461d9f8c0c..9cffe3b822 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -569,23 +569,21 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "2.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://secure.nic.cz/files/knot-dns/"
- "knot-" version ".tar.xz"))
- (sha256
- (base32
- "1vw7xx7bm440jwrpvdd04vrp6ccz2b11swcn9msvs62hf0kdjjj9"))
- (patches
- (search-patches "knot-include-system-lmdb-header.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (with-directory-excursion "src/contrib"
- (delete-file-recursively "lmdb"))
- #t))))
+ (version "2.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://secure.nic.cz/files/knot-dns/"
+ "knot-" version ".tar.xz"))
+ (sha256
+ (base32 "1im2wb8hl394mzni1wavmvfqd7il8s28kcz8w3s4v05nbhzg06xj"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libraries.
+ (with-directory-excursion "src/contrib"
+ (delete-file-recursively "lmdb"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/knot-include-system-lmdb-header.patch b/gnu/packages/patches/knot-include-system-lmdb-header.patch
deleted file mode 100644
index 5c5c0beabc..0000000000
--- a/gnu/packages/patches/knot-include-system-lmdb-header.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Wed, 20 Mar 2019 00:08:00 +0100
-Subject: [PATCH] gnu: knot: Include system <lmdb.h>.
-
-Copied verbatim from Knot master[0].
-
-[0]: https://gitlab.labs.nic.cz/knot/knot-dns/commit/b557430cffbb1c6b30617a394b02acc514e7e536
-
-From b557430cffbb1c6b30617a394b02acc514e7e536 Mon Sep 17 00:00:00 2001
-From: Daniel Salzman <daniel.salzman@nic.cz>
-Date: Wed, 6 Mar 2019 17:35:44 +0100
-Subject: [PATCH] journal: include proper header <lmdb.h>
-
-fixes #638
----
- src/knot/journal/knot_lmdb.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/knot/journal/knot_lmdb.h b/src/knot/journal/knot_lmdb.h
-index 35a88845c..b1d09cbb4 100644
---- a/src/knot/journal/knot_lmdb.h
-+++ b/src/knot/journal/knot_lmdb.h
-@@ -16,7 +16,7 @@
-
- #pragma once
-
--#include "contrib/lmdb/lmdb.h"
-+#include <lmdb.h>
-
- #include <stdbool.h>
- #include <stdlib.h>
---
-2.18.1
-