summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-23 05:24:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-25 07:20:00 +0100
commit14bc88a9b3e467f6d588ecbca3766fa0d126c0a0 (patch)
tree624e285c1e3224d819361893c4bb760fce6cf14e /gnu/packages/dns.scm
parenta1bf1e6faf62202149b3271f5a3ee62bfa8bd5a1 (diff)
downloadguix-patches-14bc88a9b3e467f6d588ecbca3766fa0d126c0a0.tar
guix-patches-14bc88a9b3e467f6d588ecbca3766fa0d126c0a0.tar.gz
gnu: ldns: Gexp arguments.
* gnu/packages/dns.scm (ldns)[arguments]: Rewrite as a keyword/gexp list.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm77
1 files changed, 33 insertions, 44 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 7aa702caea..230a888307 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -79,6 +79,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -157,50 +158,38 @@ protocol.")
(build-system gnu-build-system)
(outputs '("out" "drill" "examples" "pyldns"))
(arguments
- `( ;; Tests require Tpkg.
- ;; https://tpkg.github.io/
- #:tests? #f
- #:configure-flags
- (list
- "--disable-static"
- "--enable-gost-anyway"
- "--enable-rrtype-ninfo"
- "--enable-rrtype-rkey"
- "--enable-rrtype-ta"
- "--enable-rrtype-avc"
- "--enable-rrtype-doa"
- "--enable-rrtype-amtrelay"
- "--with-drill"
- "--with-examples"
- "--with-pyldns"
- ;; Perl module DNS::LDNS not available.
- ;; https://github.com/erikoest/DNS-LDNS.git
- ;; "--with-p5-dns-ldns"
- (string-append "--with-ssl="
- (assoc-ref %build-inputs "openssl"))
- (string-append "--with-ca-path="
- (assoc-ref %build-inputs "nss-certs")
- "/etc/ssl/certs"))
- #:make-flags
- (list
- (string-append "drillbindir="
- (assoc-ref %outputs "drill")
- "/bin")
- (string-append "drillmandir="
- (assoc-ref %outputs "drill")
- "/share/man")
- (string-append "examplesbindir="
- (assoc-ref %outputs "examples")
- "/bin")
- (string-append "examplesmandir="
- (assoc-ref %outputs "examples")
- "/share/man")
- (string-append "python_site="
- (assoc-ref %outputs "pyldns")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages"))))
+ (list
+ #:tests? #f ; tests require <https://tpkg.github.io>
+ #:configure-flags
+ #~(list
+ "--disable-static"
+ "--enable-gost-anyway"
+ "--enable-rrtype-ninfo"
+ "--enable-rrtype-rkey"
+ "--enable-rrtype-ta"
+ "--enable-rrtype-avc"
+ "--enable-rrtype-doa"
+ "--enable-rrtype-amtrelay"
+ "--with-drill"
+ "--with-examples"
+ "--with-pyldns"
+ ;; Perl module DNS::LDNS not available.
+ ;; https://github.com/erikoest/DNS-LDNS.git
+ ;; "--with-p5-dns-ldns"
+ (string-append "--with-ssl=" #$(this-package-input "openssl"))
+ (string-append "--with-ca-path=" #$(this-package-input "nss-certs")
+ "/etc/ssl/certs"))
+ #:make-flags
+ #~(list
+ (string-append "drillbindir=" #$output:drill "/bin")
+ (string-append "drillmandir=" #$output:drill "/share/man")
+ (string-append "examplesbindir=" #$output:examples "/bin")
+ (string-append "examplesmandir=" #$output:examples "/share/man")
+ (string-append "python_site=" #$output:pyldns "/lib/python"
+ #$(version-major+minor (package-version
+ (this-package-input
+ "python-wrapper")))
+ "/site-packages"))))
(native-inputs
(list doxygen perl perl-devel-checklib pkg-config swig))
(inputs