summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-22 22:45:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-25 07:20:00 +0100
commita1bf1e6faf62202149b3271f5a3ee62bfa8bd5a1 (patch)
tree81d3d80dbbab7a4c3c44e85bc617cde60550e8bc /gnu/packages/dns.scm
parent7e004558533e8443975d23918334b96e328d002a (diff)
downloadguix-patches-a1bf1e6faf62202149b3271f5a3ee62bfa8bd5a1.tar
guix-patches-a1bf1e6faf62202149b3271f5a3ee62bfa8bd5a1.tar.gz
gnu: ldns: Make Python non-native.
The ldns-config and _ldns.la files keep a reference to its /include and /lib, respectively. The package won't currently cross-build. * gnu/packages/dns.scm (ldns)[native-inputs]: Move python-wrapper from here… [inputs]: …to here.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 71ff78cf31..7aa702caea 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -202,14 +202,9 @@ protocol.")
(package-version python))
"/site-packages"))))
(native-inputs
- (list doxygen
- perl
- perl-devel-checklib
- pkg-config
- python-wrapper
- swig))
+ (list doxygen perl perl-devel-checklib pkg-config swig))
(inputs
- (list libpcap nss-certs openssl))
+ (list libpcap nss-certs openssl python-wrapper))
(synopsis "DNS library that facilitates DNS tool programming")
(description "LDNS aims to simplify DNS programming, it supports recent
RFCs like the DNSSEC documents, and allows developers to easily create