summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-11 17:59:16 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:57 +0200
commit6673d1b58b8f46c1236a3484f44d7afd82e37a0f (patch)
tree95a5ebf0b95ac331be6e7a31f27d6982aed27560 /gnu/packages/django.scm
parent87f067657ef0d51676d5e7980f7da78c23ab9b33 (diff)
downloadguix-patches-6673d1b58b8f46c1236a3484f44d7afd82e37a0f.tar
guix-patches-6673d1b58b8f46c1236a3484f44d7afd82e37a0f.tar.gz
gnu: Deprecate python-django-jsonfield.
* gnu/packages/django.scm (python-django-jsonfield): Rewrite in terms of DEPRECATED-PACKAGE with PYTHON-DJANGO as the replacement.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm28
1 files changed, 2 insertions, 26 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7f7b96b787..943958f089 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -592,33 +592,9 @@ provides certain advantages over the builtin Jinja2 backend in Django, for
example, explicit calls to callables from templates and better performance.")
(license license:bsd-3)))
+;; JSONField is now built-in to Django, obsoleting this package.
(define-public python-django-jsonfield
- (package
- (name "python-django-jsonfield")
- (version "1.0.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "jsonfield" version))
- (sha256
- (base32
- "19x4lak0hg9c20r7mvf27w7i8r6i4sg2g0ypmlmp2665fnk76zvy"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* "jsonfield/tests.py"
- (("django.forms.util") "django.forms.utils")))))))
- (propagated-inputs
- `(("python-django" ,python-django)))
- (home-page "https://github.com/bradjasper/django-jsonfield")
- (synopsis "Store validated JSON in your model")
- (description
- "Django-jsonfield is a reusable Django field that allows you to store
-validated JSON in your model. It silently takes care of serialization. To
-use, simply add the field to one of your models.")
- (license license:expat)))
+ (deprecated-package "python-django-jsonfield" python-django))
(define-public python-dj-database-url
(package