summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-11 17:22:48 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:57 +0200
commit87f067657ef0d51676d5e7980f7da78c23ab9b33 (patch)
treed19b314597a9fb0af2d6ddc83f970a8f33a02b85 /gnu/packages/django.scm
parente06e250d48317ff73ae64353c160b7c01994c827 (diff)
downloadguix-patches-87f067657ef0d51676d5e7980f7da78c23ab9b33.tar
guix-patches-87f067657ef0d51676d5e7980f7da78c23ab9b33.tar.gz
gnu: Remove python2 versions of Django packages.
Python 2 is EOL and not supported by current versions of Django. * gnu/packages/django.scm (python-django, python-django-tagging)[properties]: Remove PYTHON2-VARIANT. * gnu/packages/django.scm (python2-django, python2-django-simple-math-captcha, python2-pytest-django, python2-django-filter, python2-django-allauth, python2-django-gravatar2, python2-django-assets, python2-django-jsonfield, python2-dj-database-url, python2-django-bulk-update, python2-django-contact-form, python2-django-contrib-comments, python2-django-overextends, python2-django-redis, python2-django-rq, python2-django-sortedm2m, python2-django-appconf, python2-django-statici18n, python2-django-tagging): Remove variables.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm82
1 files changed, 1 insertions, 81 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index d709d5bf6d..7f7b96b787 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -126,21 +126,7 @@ development and clean, pragmatic design. It provides many tools for building
any Web site. Django focuses on automating as much as possible and adhering
to the @dfn{don't repeat yourself} (DRY) principle.")
(license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-django))
- (cpe-name . "django")))))
-
-(define-public python2-django
- (let ((base (package-with-python2 (strip-python2-variant python-django))))
- (package
- (inherit base)
- (native-inputs
- `(;; Test requirements for Python 2 taken from
- ;; tests/requirements/py3.txt: enum34 and mock.
- ("python2-enum34" ,python2-enum34)
- ("python2-mock" ,python2-mock)
- ;; When adding memcached mind: for Python 2 memcached <= 1.53 is
- ;; required.
- ,@(package-native-inputs base))))))
+ (properties `((cpe-name . "django")))))
(define-public python-django-2.2
(package
@@ -238,9 +224,6 @@ with no settings.py configuration necessary, but instead can be configured
with arguments to the field constructor.")
(license license:asl2.0)))
-(define-public python2-django-simple-math-captcha
- (package-with-python2 python-django-simple-math-captcha))
-
(define-public python-django-classy-tags
(package
(name "python-django-classy-tags")
@@ -370,9 +353,6 @@ size and quality.")
useful tools for testing Django applications and projects.")
(license license:bsd-3)))
-(define-public python2-pytest-django
- (package-with-python2 python-pytest-django))
-
(define-public python-django-haystack
(package
(name "python-django-haystack")
@@ -452,9 +432,6 @@ filter down a queryset based on a model’s fields, displaying the form to let
them do this.")
(license license:bsd-3)))
-(define-public python2-django-filter
- (package-with-python2 python-django-filter))
-
(define-public python-django-allauth
(package
(name "python-django-allauth")
@@ -491,9 +468,6 @@ registration, account management as well as 3rd party (social)
account authentication.")
(license license:expat)))
-(define-public python2-django-allauth
- (package-with-python2 python-django-allauth))
-
(define-public python-django-debug-toolbar
(package
(name "python-django-debug-toolbar")
@@ -553,9 +527,6 @@ request and response as a toolbar on the rendered page.")
templatetags and a full test suite.")
(license license:expat)))
-(define-public python2-django-gravatar2
- (package-with-python2 python-django-gravatar2))
-
(define-public python-django-assets
(package
(name "python-django-assets")
@@ -580,9 +551,6 @@ files. Integrates the webassets library with Django, adding support for
merging, minifying and compiling CSS and Javascript files.")
(license license:bsd-2)))
-(define-public python2-django-assets
- (package-with-python2 python-django-assets))
-
(define-public python-django-jinja
(package
(name "python-django-jinja")
@@ -652,9 +620,6 @@ validated JSON in your model. It silently takes care of serialization. To
use, simply add the field to one of your models.")
(license license:expat)))
-(define-public python2-django-jsonfield
- (package-with-python2 python-django-jsonfield))
-
(define-public python-dj-database-url
(package
(name "python-dj-database-url")
@@ -677,9 +642,6 @@ dictionary, populated with all the data specified in your URL. There is also a
conn_max_age argument to easily enable Django’s connection pool.")
(license license:bsd-2)))
-(define-public python2-dj-database-url
- (package-with-python2 python-dj-database-url))
-
(define-public python-django-picklefield
(package
(name "python-django-picklefield")
@@ -731,9 +693,6 @@ conn_max_age argument to easily enable Django’s connection pool.")
project aims to bulk update given objects using one query over Django ORM.")
(license license:expat)))
-(define-public python2-django-bulk-update
- (package-with-python2 python-django-bulk-update))
-
(define-public python-django-contact-form
(package
(name "python-django-contact-form")
@@ -766,9 +725,6 @@ project aims to bulk update given objects using one query over Django ORM.")
for Django sites.")
(license license:bsd-3)))
-(define-public python2-django-contact-form
- (package-with-python2 python-django-contact-form))
-
(define-public python-django-contrib-comments
(package
(name "python-django-contrib-comments")
@@ -791,9 +747,6 @@ used to attach comments to any model, so you can use it for comments on blog
entries, photos, book chapters, or anything else.")
(license license:bsd-3)))
-(define-public python2-django-contrib-comments
- (package-with-python2 python-django-contrib-comments))
-
(define-public python-django-overextends
(package
(name "python-django-overextends")
@@ -824,9 +777,6 @@ override and extend templates from other reusable apps, in your own Django
project.")
(license license:bsd-2)))
-(define-public python2-django-overextends
- (package-with-python2 python-django-overextends))
-
(define-public python-django-pipeline
(package
(name "python-django-pipeline")
@@ -905,9 +855,6 @@ support, and optional data-URI image and font embedding.")
"Full featured redis cache backend for Django.")
(license license:bsd-3)))
-(define-public python2-django-redis
- (package-with-python2 python-django-redis))
-
(define-public python-django-rq
(package
(name "python-django-rq")
@@ -944,9 +891,6 @@ Django-RQ is a simple app that allows you to configure your queues in django's
settings.py and easily use them in your project.")
(license license:expat)))
-(define-public python2-django-rq
- (package-with-python2 python-django-rq))
-
(define-public python-django-q
(package
(name "python-django-q")
@@ -1002,9 +946,6 @@ The provided SortedManyToManyField behaves like the original one but remembers
the order of added relations.")
(license license:bsd-3)))
-(define-public python2-django-sortedm2m
- (package-with-python2 python-django-sortedm2m))
-
(define-public python-django-appconf
(package
(name "python-django-appconf")
@@ -1036,9 +977,6 @@ django-appconf and can't easily be used as a replacement. The similarity in
name is purely coincidental.")
(license license:bsd-3)))
-(define-public python2-django-appconf
- (package-with-python2 python-django-appconf))
-
(define-public python-django-statici18n
(package
(name "python-django-statici18n")
@@ -1075,9 +1013,6 @@ name is purely coincidental.")
static files.")
(license license:bsd-3)))
-(define-public python2-django-statici18n
- (package-with-python2 python-django-statici18n))
-
(define-public python-django-tagging
(package
(name "python-django-tagging")
@@ -1104,23 +1039,8 @@ static files.")
(description "This package provides a generic tagging application for
Django projects, which allows association of a number of tags with any
@code{Model} instance and makes retrieval of tags simple.")
- (properties `((python2-variant . ,(delay python2-django-tagging))))
(license license:bsd-3)))
-(define-public python2-django-tagging
- (let ((base (package-with-python2
- (strip-python2-variant python-django-tagging))))
- (package
- (inherit base)
- (version "0.4.6")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "django-tagging" version))
- (sha256
- (base32
- "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1")))))))
-
(define-public python-djangorestframework
(package
(name "python-djangorestframework")