summaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 01:52:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:17 +0100
commitf9fe99b4cd65bba023fca109c9f2f63828f00e48 (patch)
tree388fdc6dbea2220260681ea1a6058830ff682ed5 /gnu/packages/digest.scm
parent7608d2d05dc8a0f8a1621c80219244e2dc3e9940 (diff)
downloadguix-patches-f9fe99b4cd65bba023fca109c9f2f63828f00e48.tar
guix-patches-f9fe99b4cd65bba023fca109c9f2f63828f00e48.tar.gz
gnu: xxhash: Use G-expressions.
* gnu/packages/digest.scm (xxhash)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 309a94d3e8..4211848fdb 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -19,6 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages digest)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -79,24 +80,24 @@ Zig, V, and Nim programming language standard libraries.")
(base32 "1h6080lvcr5mpbvy4fhb4i7wvhpy72nrixk3djmpai4hxq41hsnr"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- ,(match (or (%current-target-system)
- (%current-system))
- ;; Detect vector instruction set at run time.
- ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
- (_ "DISPATCH=0"))
- "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-man-page-links
- ;; https://github.com/Cyan4973/xxHash/issues/647
- (lambda _
- (substitute* "Makefile"
- (("ln -sf \\$\\(MAN\\)")
- "ln -sf xxhsum.1"))))
- (delete 'configure)))) ; no configure script
+ (list #:make-flags
+ #~(list #$(string-append "CC=" (cc-for-target))
+ #$(match (or (%current-target-system)
+ (%current-system))
+ ;; Detect vector instruction set at run time.
+ ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
+ (_ "DISPATCH=0"))
+ "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-man-page-links
+ ;; https://github.com/Cyan4973/xxHash/issues/647
+ (lambda _
+ (substitute* "Makefile"
+ (("ln -sf \\$\\(MAN\\)")
+ "ln -sf xxhsum.1"))))
+ (delete 'configure)))) ; no configure script
(home-page "https://cyan4973.github.io/xxHash/")
(synopsis "Extremely fast hash algorithm")
(description