summaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 01:50:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:17 +0100
commit7608d2d05dc8a0f8a1621c80219244e2dc3e9940 (patch)
treea973412ce2f752b3165b3b2776433c84579769f4 /gnu/packages/digest.scm
parent24b04f5d4e82284a48f07213bd02b83401db8898 (diff)
downloadguix-patches-7608d2d05dc8a0f8a1621c80219244e2dc3e9940.tar
guix-patches-7608d2d05dc8a0f8a1621c80219244e2dc3e9940.tar.gz
gnu: xxhash: Update to 0.8.1.
* gnu/packages/digest.scm (xxhash): Update to 0.8.1. [arguments]: Add a new 'fix-man-page-links phase.
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 0af6720c03..309a94d3e8 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -66,7 +66,8 @@ Zig, V, and Nim programming language standard libraries.")
(define-public xxhash
(package
(name "xxhash")
- (version "0.8.0")
+ ;; XXX Remove the 'fix-man-page-links phase when updating.
+ (version "0.8.1")
(source
(origin
(method git-fetch)
@@ -75,7 +76,7 @@ Zig, V, and Nim programming language standard libraries.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0hpbzdd6kfki5f61g103vp7pfczqkdj0js63avl0ss552jfb8h96"))))
+ (base32 "1h6080lvcr5mpbvy4fhb4i7wvhpy72nrixk3djmpai4hxq41hsnr"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -89,6 +90,12 @@ Zig, V, and Nim programming language standard libraries.")
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-man-page-links
+ ;; https://github.com/Cyan4973/xxHash/issues/647
+ (lambda _
+ (substitute* "Makefile"
+ (("ln -sf \\$\\(MAN\\)")
+ "ln -sf xxhsum.1"))))
(delete 'configure)))) ; no configure script
(home-page "https://cyan4973.github.io/xxHash/")
(synopsis "Extremely fast hash algorithm")