summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-21 23:52:59 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-21 23:54:48 -0600
commitb6d937d99ee2526f56fbd60e2304a7012faf69d1 (patch)
tree3bb5a8849b4b75976262e3a88061b16908d64f8c /gnu/packages/debug.scm
parent2d8211ab30eb226c6117acf7d066c4e6c6140154 (diff)
downloadguix-patches-b6d937d99ee2526f56fbd60e2304a7012faf69d1.tar
guix-patches-b6d937d99ee2526f56fbd60e2304a7012faf69d1.tar.gz
gnu: american-fuzzy-lop: Update to 1.96b.
* gnu/packages/debug.scm (american-fuzzy-lop): Update to 1.96b. [arguments]: Create symbolic link to custom qemu, rather than copying.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 3248922ba6..72fd993037 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -169,7 +169,7 @@ tools that process C/C++ code.")
(_ "UNSUPPORTED"))))
(package
(name "american-fuzzy-lop")
- (version "1.86b") ;It seems all releases have the 'b' suffix
+ (version "1.96b") ;It seems all releases have the 'b' suffix
(source
(origin
(method url-fetch)
@@ -177,7 +177,7 @@ tools that process C/C++ code.")
"afl-" version ".tgz"))
(sha256
(base32
- "1by9ncf6lgcyibzqwyla34jv64sd66mn8zhgjz2pcgsds51qwn0r"))))
+ "0z7j231p6v2h1dxxijgdzj1lq1lxr8cxllwf6iyv7p4ki5pv1gh3"))))
(build-system gnu-build-system)
(inputs
`(("custom-qemu"
@@ -238,8 +238,8 @@ tools that process C/C++ code.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((qemu (assoc-ref inputs "custom-qemu"))
(out (assoc-ref outputs "out")))
- (copy-file (string-append qemu "/bin/qemu-" ,machine)
- (string-append out "/bin/afl-qemu-trace"))
+ (symlink (string-append qemu "/bin/qemu-" ,machine)
+ (string-append out "/bin/afl-qemu-trace"))
#t)))
(delete 'check))))
(supported-systems (fold delete