summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-21 23:19:32 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-21 23:54:48 -0600
commit2d8211ab30eb226c6117acf7d066c4e6c6140154 (patch)
tree90c70b7c28653b02e788b7391c595908da6feaee /gnu/packages/debug.scm
parent765973cd651d597bf9cd42ea05b50c5a8ebee2f3 (diff)
downloadguix-patches-2d8211ab30eb226c6117acf7d066c4e6c6140154.tar
guix-patches-2d8211ab30eb226c6117acf7d066c4e6c6140154.tar.gz
gnu: american-fuzzy-lop: Fix qemu configure flags.
Fixes regression introduced in 06da1a6. * gnu/packages/debug.scm (american-fuzzy-lop)[qemu]: Override inherited #:configure-flags.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index dc94f97657..3248922ba6 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -190,11 +190,13 @@ tools that process C/C++ code.")
;; afl only supports using a single afl-qemu-trace executable, so
;; we only build qemu for the native target.
(arguments
- `(#:configure-flags
- (list (string-append "--target-list=" ,machine "-linux-user"))
- #:modules ((srfi srfi-1)
+ `(#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
,@(substitute-keyword-arguments (package-arguments qemu-2.3.0)
+ ((#:configure-flags config-flags)
+ ``(,(string-append "--target-list=" ,machine "-linux-user")
+ ,@(remove (λ (f) (string-prefix? "--target-list=" f))
+ ,config-flags)))
((#:phases qemu-phases)
`(modify-phases ,qemu-phases
(add-after