summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 14:46:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 14:46:40 +0100
commitc9e75159706368be7b0b9d8a8fe33dc2786e37a7 (patch)
treef3e2cb01245a1aadadbf94d4e1214962c80df3c2 /gnu/packages/datastructures.scm
parentd1293d426dcfb711a8c156ff66b7cdc93ff32fef (diff)
downloadguix-patches-c9e75159706368be7b0b9d8a8fe33dc2786e37a7.tar
guix-patches-c9e75159706368be7b0b9d8a8fe33dc2786e37a7.tar.gz
gnu: uthash: Use INVOKE.
* gnu/packages/datastructures.scm (uthash)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 8fca504915..27fe882043 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -171,8 +171,7 @@ queues, stacks, and doubly-linked lists.")
(replace 'check
(lambda* (#:key make-flags #:allow-other-keys)
(with-directory-excursion "tests"
- (zero? (apply system* "make"
- make-flags)))))
+ (apply invoke "make" make-flags))))
(replace 'install
;; There is no top-level Makefile to do this for us.
(lambda* (#:key outputs #:allow-other-keys)