summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/datastructures.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 8fca504915..27fe882043 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -171,8 +171,7 @@ queues, stacks, and doubly-linked lists.")
(replace 'check
(lambda* (#:key make-flags #:allow-other-keys)
(with-directory-excursion "tests"
- (zero? (apply system* "make"
- make-flags)))))
+ (apply invoke "make" make-flags))))
(replace 'install
;; There is no top-level Makefile to do this for us.
(lambda* (#:key outputs #:allow-other-keys)