summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-15 22:14:01 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-15 23:27:59 +0100
commitea843715b56c935cfb73c6fed23c31c32ec13712 (patch)
tree1d6f23dbf65adc942b624b2c100c8d92f80abea8 /gnu/packages/cups.scm
parent7a7d5f66412fb74eb94439f3a566230a30ea2f7d (diff)
downloadguix-patches-ea843715b56c935cfb73c6fed23c31c32ec13712.tar
guix-patches-ea843715b56c935cfb73c6fed23c31c32ec13712.tar.gz
gnu: hplip: Do not keep reference to GCC.
Previously the 'dat2drv' and 'locatedriver' programs would be installed to share/hplip, and thus they would not get stripped during the 'strip' phase. Consequently, they retained references to GCC. * gnu/packages/cups.scm (hplip)[source](snippet): Change "data2drvdir" and "locatedriverdir" in Makefile.in.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index fa6e3ae2b6..b943444a14 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -430,9 +430,19 @@ should only be used as part of the Guix cups-pk-helper service.")
(lambda (file stat)
(elf-file? file))))
(delete-file "prnt/hpcups/ImageProcessor.h")
+
;; Fix type mismatch.
(substitute* "prnt/hpcups/genPCLm.cpp"
(("boolean") "bool"))
+
+ ;; Install binaries under libexec/hplip instead of
+ ;; share/hplip; that'll at least ensure they get stripped.
+ ;; It's not even clear that they're of any use though...
+ (substitute* "Makefile.in"
+ (("^dat2drvdir =.*")
+ "dat2drvdir = $(pkglibexecdir)\n")
+ (("^locatedriverdir =.*")
+ "locatedriverdir = $(pkglibexecdir)\n"))
#t))))
(build-system gnu-build-system)
(home-page "https://developers.hp.com/hp-linux-imaging-and-printing")