summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-15 22:12:07 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-15 23:27:59 +0100
commit7a7d5f66412fb74eb94439f3a566230a30ea2f7d (patch)
treea2c7cb108d82b85214dc99fa2613bda97154470e /gnu/packages/cups.scm
parent11e1df56e29e8e9f9dbe1beaf6afb902c33c9198 (diff)
downloadguix-patches-7a7d5f66412fb74eb94439f3a566230a30ea2f7d.tar
guix-patches-7a7d5f66412fb74eb94439f3a566230a30ea2f7d.tar.gz
gnu: hplip: Remove pre-built executable from the source.
* gnu/packages/cups.scm (hplip)[source](snippet): Remove all the files matching 'elf-file?', not just ".so" files. This includes the 'locatedriver' executable found in the upstream tarball.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 9f23b8e9ae..fa6e3ae2b6 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
@@ -423,8 +423,12 @@ should only be used as part of the Guix cups-pk-helper service.")
(patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet
'(begin
- ;; Delete non-free blobs
- (for-each delete-file (find-files "." "\\.so$"))
+ ;; Delete non-free blobs: .so files, pre-compiled
+ ;; 'locatedriver' executable, etc.
+ (for-each delete-file
+ (find-files "."
+ (lambda (file stat)
+ (elf-file? file))))
(delete-file "prnt/hpcups/ImageProcessor.h")
;; Fix type mismatch.
(substitute* "prnt/hpcups/genPCLm.cpp"