summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-21 02:23:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-21 02:24:40 +0200
commit0a385196942bdd73b834b892b600a0fade076933 (patch)
treee079e1ba08e43b968bccdf6197a9c02b0dbe0108 /gnu/packages/crypto.scm
parent6b6dbff44ee3063c2fce5b5245a0a4046b3145d2 (diff)
downloadguix-patches-0a385196942bdd73b834b892b600a0fade076933.tar
guix-patches-0a385196942bdd73b834b892b600a0fade076933.tar.gz
gnu: eschalot: Cross-compile.
* gnu/packages/crypto.scm (eschalot)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c30c949dc0..4654be17b3 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -362,7 +362,7 @@ secure operations. ")
`(("openssl" ,openssl-1.0))) ; for openssl/{bn,pem,rsa,sha}.h
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc"
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "INSTALL=" "install"))
;; XXX: make test would run a !VERY! long hashing of names with the use