summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 23:04:12 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 23:04:12 +0200
commit9f27579fb9ce4c8f464653e24c507e3e39748f24 (patch)
tree5d851714c069c2950fef0f566a7b2205b28d01b3 /gnu/packages/cran.scm
parent22950d66152e1bbd9ab445fc596e1cde85b15807 (diff)
downloadguix-patches-9f27579fb9ce4c8f464653e24c507e3e39748f24.tar
guix-patches-9f27579fb9ce4c8f464653e24c507e3e39748f24.tar.gz
gnu: Add r-phylobase.
* gnu/packages/cran.scm (r-phylobase): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index efba6e217b..b40298527c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12572,6 +12572,31 @@ library which allows parsing of NEXUS, Newick and other phylogenetic tree
@code{read_newick_phylo()} and @code{read_nexus_phylo()}.")
(license license:bsd-2)))
+(define-public r-phylobase
+ (package
+ (name "r-phylobase")
+ (version "0.8.10")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "phylobase" version))
+ (sha256
+ (base32
+ "0jzr1gdvmi4l640hwwzh9bxqmpja69bn3ygnaqx37awvyh7khi2s"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ade4" ,r-ade4)
+ ("r-ape" ,r-ape)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rncl" ,r-rncl)
+ ("r-rnexml" ,r-rnexml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/fmichonneau/phylobase")
+ (synopsis "Base package for phylogenetic structures and comparative data")
+ (description "This package provides a base @code{S4} class for comparative
+methods, incorporating one or more trees and trait data.")
+ (license license:gpl2+)))
+
(define-public r-rnexml
(package
(name "r-rnexml")