summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 22:58:18 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 22:58:18 +0200
commit22950d66152e1bbd9ab445fc596e1cde85b15807 (patch)
treea3865bdacd57a99c16d327f1c214ff99f30e5a5b /gnu/packages/cran.scm
parent416eaacbb13361e0fa7f1ff573543445269f5e59 (diff)
downloadguix-patches-22950d66152e1bbd9ab445fc596e1cde85b15807.tar
guix-patches-22950d66152e1bbd9ab445fc596e1cde85b15807.tar.gz
gnu: Add r-rncl.
* gnu/packages/cran.scm (r-rncl): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 266f509732..efba6e217b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12548,6 +12548,30 @@ Helene Touzet and Jean-Stephane Varre, 2007, Algorithms Mol Biol:2, 15.
Touzet and Varre (2007).")
(license license:gpl2)))
+(define-public r-rncl
+ (package
+ (name "r-rncl")
+ (version "0.8.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rncl" version))
+ (sha256
+ (base32
+ "0ss9jqrvv7bhvl5j74cjrp8r866d9dlavrbbfscwz3mhkgfx06bb"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-progress" ,r-progress)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/fmichonneau/rncl")
+ (synopsis "Interface to the Nexus class library")
+ (description "This package provides an interface to the Nexus class
+library which allows parsing of NEXUS, Newick and other phylogenetic tree
+ file formats. It provides elements of the file that can be used to build
+ phylogenetic objects such as @code{ape}'s @code{phylo} or @code{phylobase}'s
+@code{phylo4(d)}. This functionality is demonstrated with
+@code{read_newick_phylo()} and @code{read_nexus_phylo()}.")
+ (license license:bsd-2)))
+
(define-public r-rnexml
(package
(name "r-rnexml")