summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-13 17:21:42 -0800
committerLeo Famulari <leo@famulari.name>2018-01-13 17:23:31 -0800
commitbad12e839c2f7823c45aa0121f7d5c9bb70905b7 (patch)
treeb2575fc93eba6aa91125a2245fc09c7d0486ff8f /gnu/packages/cpp.scm
parente8b409741baf3b9de30faa8683722375196dd1e9 (diff)
downloadguix-patches-bad12e839c2f7823c45aa0121f7d5c9bb70905b7.tar
guix-patches-bad12e839c2f7823c45aa0121f7d5c9bb70905b7.tar.gz
gnu: rct: Re-categorize some inputs.
OpenSSL and zlib are referred to by the built package, so we make them regular inputs. This is a followup to commit e8b409741baf3b9de30faa8683722375196dd1e9. * gnu/packages/cpp.scm (rct)[native-inputs]: Move openssl and zlib to ... [inputs]: ... new field.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8691531070..7f711d5542 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -89,8 +89,9 @@ operating system functions.")
'("-DWITH_TESTS=ON"))) ; To run the test suite
(native-inputs
`(("cppunit" ,cppunit)
- ("openssl" ,openssl)
- ("pkg-config" ,pkg-config)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "C++ library providing Qt-like APIs on top of the STL")
(description "Rct is a set of C++ tools that provide nicer (more Qt-like)