summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-01-13 16:59:01 -0800
committerLeo Famulari <leo@famulari.name>2018-01-13 17:11:49 -0800
commite8b409741baf3b9de30faa8683722375196dd1e9 (patch)
tree45b720bf90612a9404e9d7159fd0c53f4016e77f /gnu/packages/cpp.scm
parenta03abe78884a166c8943ce3a5dac7d290010885e (diff)
downloadguix-patches-e8b409741baf3b9de30faa8683722375196dd1e9.tar
guix-patches-e8b409741baf3b9de30faa8683722375196dd1e9.tar.gz
gnu: Add rct.
* gnu/packages/cpp.scm (rct): New variable.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4fd499f5f3..8691531070 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,9 +22,15 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages autotools))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls))
(define-public libzen
(package
@@ -58,3 +65,35 @@
strings, configuration, bit streams, threading, translation, and cross-platform
operating system functions.")
(license license:zlib)))
+
+(define-public rct
+ (let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
+ (revision "1")
+ (version (git-version "0.0.0" revision commit)))
+ (package
+ (name "rct")
+ (version version)
+ (home-page "https://github.com/Andersbakken/rct")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1m2931jacka27ghnpgf1z1plkkr64z0pga4r4zdrfpp2d7xnrdvb"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DWITH_TESTS=ON"))) ; To run the test suite
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("openssl" ,openssl)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)))
+ (synopsis "C++ library providing Qt-like APIs on top of the STL")
+ (description "Rct is a set of C++ tools that provide nicer (more Qt-like)
+ APIs on top of Standard Template Library (@dfn{STL}) classes.")
+ (license (list license:expat ; cJSON
+ license:bsd-4))))) ; everything else (LICENSE.txt)