summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-16 19:51:54 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-18 04:30:41 +0100
commit7537ec816ffe0aaa6677c53604ac12fe9d9ca250 (patch)
tree1314153ab7af50b85a46ba951d5d002da2530bd4 /gnu/packages/coq.scm
parent4423caece69f6142eeff562007ce53b9144de334 (diff)
downloadguix-patches-7537ec816ffe0aaa6677c53604ac12fe9d9ca250.tar
guix-patches-7537ec816ffe0aaa6677c53604ac12fe9d9ca250.tar.gz
gnu: coq-stdpp: Adjust '#:make-flags'.
* gnu/packages/coq.scm (coq-stdpp)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index aeba0eb5da..a0579f8869 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -633,15 +633,12 @@ also provided in Coq, without associated proofs.")
`(("coq" ,coq)))
(arguments
`(#:tests? #f ; Tests are executed during build phase.
+ #:make-flags (list (string-append "COQLIBINSTALL="
+ (assoc-ref %outputs "out")
+ "/lib/coq/user-contrib"))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make"
- (string-append "COQLIB=" (assoc-ref outputs "out")
- "/lib/coq/")
- "install"))))))
+ (delete 'configure))))
(description "This project contains an extended \"Standard Library\" for
Coq called coq-std++. The key features are:
@itemize