summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-16 19:51:53 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-18 04:25:38 +0100
commit4423caece69f6142eeff562007ce53b9144de334 (patch)
tree042319a74b034336b11eb7b85f15dbc4ee61be5e /gnu/packages/coq.scm
parent5d7d64ff8567abb32defbf00038fab789353a8d5 (diff)
downloadguix-patches-4423caece69f6142eeff562007ce53b9144de334.tar
guix-patches-4423caece69f6142eeff562007ce53b9144de334.tar.gz
gnu: coq-equations: Adjust '#:make-flags'.
* gnu/packages/coq.scm (coq-equations)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index fc739a0475..aeba0eb5da 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -547,17 +547,14 @@ uses Ltac to synthesize the substitution operation.")
`(("ocaml-zarith" ,ocaml-zarith)))
(arguments
`(#:test-target "test-suite"
+ #:make-flags (list (string-append "COQLIBINSTALL="
+ (assoc-ref %outputs "out")
+ "/lib/coq/user-contrib"))
#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (invoke "sh" "./configure.sh")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make"
- (string-append "COQLIB=" (assoc-ref outputs "out")
- "/lib/coq/")
- "install"))))))
+ (invoke "sh" "./configure.sh"))))))
(home-page "https://mattam82.github.io/Coq-Equations/")
(synopsis "Function definition plugin for Coq")
(description "Equations provides a notation for writing programs