summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-12 14:35:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 01:20:19 +0200
commit28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9 (patch)
treefe1b9ce5fdda2230610ad9e815da3e2b65cc733d /gnu/packages/compression.scm
parentfaa83a040a3008782091638133e7bfaaae539857 (diff)
downloadguix-patches-28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9.tar
guix-patches-28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9.tar.gz
gnu: Rename google-brotli back to brotli.
Sorry for the noise, but good riddance. Our nonstandard name for this package has caused confusion since it was added. For example, the duplicate python-brotli and python-google-brotli packages added later, with the latter name making even less sense. The Python packages will be fixed in the next commit. * gnu/packages/compression.scm (google-brotli): Redefine as a deprecated-package, with… (brotli): …restored to canonical status. (python-google-brotli)[inherit]: Adjust accordingly. * gnu/packages/databases.scm (apache-arrow)[inputs]: Adjust accordingly. * gnu/packages/fontutils.scm (woff2)[inputs]: Likewise. * gnu/packages/gnome.scm (libsoup)[propagated-inputs]: Likewise. * gnu/packages/networking (wireshark)[inputs]: Likewise. * gnu/packages/node.scm (node-lts)[arguments, native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-imagecodecs)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e5641456d6..aea56a7fa9 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2169,9 +2169,9 @@ single-member files which can't be decompressed in parallel.")
non-Windows systems without running the actual installer using wine.")
(license license:zlib)))
-(define-public google-brotli
+(define-public brotli
(package
- (name "google-brotli")
+ (name "brotli")
(version "1.0.9")
(source
(origin
@@ -2222,20 +2222,19 @@ with @code{deflate} but offers more dense compression.
The specification of the Brotli Compressed Data Format is defined in RFC 7932.")
(license license:expat)))
-(define-public brotli
- ;; We used to provide an older version under the name "brotli".
- (deprecated-package "brotli" google-brotli))
+(define-public google-brotli
+ (deprecated-package "google-brotli" brotli))
(define-public python-google-brotli
(package
- (inherit google-brotli)
+ (inherit brotli)
(name "python-google-brotli")
(build-system python-build-system)
(arguments '())
- (synopsis "Python interface to google-brotli")
- (description "@code{python-google-brotli} provides a Python interface to
-@code{google-brotli}, an implementation of the Brotli lossless compression
-algorithm.")))
+ (synopsis "Python interface to Brotli")
+ (description "This package provides a Python interface to the @code{brotli}
+package, an implementation of the Brotli lossless compression algorithm.")))
+
(define-public ucl
(package