summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-12 14:35:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 01:20:19 +0200
commit28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9 (patch)
treefe1b9ce5fdda2230610ad9e815da3e2b65cc733d
parentfaa83a040a3008782091638133e7bfaaae539857 (diff)
downloadguix-patches-28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9.tar
guix-patches-28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9.tar.gz
gnu: Rename google-brotli back to brotli.
Sorry for the noise, but good riddance. Our nonstandard name for this package has caused confusion since it was added. For example, the duplicate python-brotli and python-google-brotli packages added later, with the latter name making even less sense. The Python packages will be fixed in the next commit. * gnu/packages/compression.scm (google-brotli): Redefine as a deprecated-package, with… (brotli): …restored to canonical status. (python-google-brotli)[inherit]: Adjust accordingly. * gnu/packages/databases.scm (apache-arrow)[inputs]: Adjust accordingly. * gnu/packages/fontutils.scm (woff2)[inputs]: Likewise. * gnu/packages/gnome.scm (libsoup)[propagated-inputs]: Likewise. * gnu/packages/networking (wireshark)[inputs]: Likewise. * gnu/packages/node.scm (node-lts)[arguments, native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-imagecodecs)[inputs]: Likewise.
-rw-r--r--gnu/packages/compression.scm19
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/fontutils.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/networking.scm2
-rw-r--r--gnu/packages/node.scm8
-rw-r--r--gnu/packages/python-xyz.scm2
7 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e5641456d6..aea56a7fa9 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2169,9 +2169,9 @@ single-member files which can't be decompressed in parallel.")
non-Windows systems without running the actual installer using wine.")
(license license:zlib)))
-(define-public google-brotli
+(define-public brotli
(package
- (name "google-brotli")
+ (name "brotli")
(version "1.0.9")
(source
(origin
@@ -2222,20 +2222,19 @@ with @code{deflate} but offers more dense compression.
The specification of the Brotli Compressed Data Format is defined in RFC 7932.")
(license license:expat)))
-(define-public brotli
- ;; We used to provide an older version under the name "brotli".
- (deprecated-package "brotli" google-brotli))
+(define-public google-brotli
+ (deprecated-package "google-brotli" brotli))
(define-public python-google-brotli
(package
- (inherit google-brotli)
+ (inherit brotli)
(name "python-google-brotli")
(build-system python-build-system)
(arguments '())
- (synopsis "Python interface to google-brotli")
- (description "@code{python-google-brotli} provides a Python interface to
-@code{google-brotli}, an implementation of the Brotli lossless compression
-algorithm.")))
+ (synopsis "Python interface to Brotli")
+ (description "This package provides a Python interface to the @code{brotli}
+package, an implementation of the Brotli lossless compression algorithm.")))
+
(define-public ucl
(package
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b1dd44da1c..4869e1ced3 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3798,7 +3798,7 @@ the SQL language using a syntax that reflects the resulting query.")
(inputs
`(("apache-thrift" ,apache-thrift "lib")
("boost" ,boost)
- ("brotli" ,google-brotli)
+ ("brotli" ,brotli)
("bzip2" ,bzip2)
("double-conversion" ,double-conversion)
("gflags" ,gflags)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 2d7213fd70..d173a1529e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -309,7 +309,7 @@ work with most software requiring Type 1 fonts.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("brotli" ,google-brotli)))
+ `(("brotli" ,brotli)))
(synopsis "Libraries and tools for WOFF2 font format")
(description "WOFF2 provides libraries and tools to handle the Web Open
Font Format (WOFF).")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3a682ba38a..af4b953cb0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4872,7 +4872,7 @@ libxml to ease remote use of the RESTful API.")
("httpd" ,httpd)))
(propagated-inputs
;; libsoup-2.4.pc refers to all of these (except where otherwise noted)
- `(("brotli" ,google-brotli)
+ `(("brotli" ,brotli)
("glib" ,glib)
("glib-networking" ,glib-networking) ; for GIO runtime modules
("libpsl" ,libpsl)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a0c526a83b..2829c082d1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1507,7 +1507,7 @@ of the same name.")
`(("c-ares" ,c-ares)
("glib" ,glib)
("gnutls" ,gnutls)
- ("google-brotli" ,google-brotli)
+ ("brotli" ,brotli)
("libcap" ,libcap)
("libgcrypt" ,libgcrypt)
("libnl" ,libnl)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index f8ac95884c..d0ffe8a398 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -685,7 +685,7 @@ source files.")
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(let* ((inputs (or native-inputs inputs))
(c-ares (assoc-ref inputs "c-ares"))
- (google-brotli (assoc-ref inputs "google-brotli"))
+ (brotli (assoc-ref inputs "brotli"))
(icu4c (assoc-ref inputs "icu4c"))
(nghttp2 (assoc-ref inputs "nghttp2"))
(openssl (assoc-ref inputs "openssl"))
@@ -704,7 +704,7 @@ source files.")
(string-append target
"'ldflags': ['-Wl,-rpath="
c-ares "/lib:"
- google-brotli "/lib:"
+ brotli "/lib:"
icu4c "/lib:"
nghttp2 "/lib:"
openssl "/lib:"
@@ -821,7 +821,7 @@ source files.")
(native-inputs
`(;; Runtime dependencies for binaries used as a bootstrap.
("c-ares" ,c-ares)
- ("google-brotli" ,google-brotli)
+ ("brotli" ,brotli)
("icu4c" ,icu4c-67)
("libuv" ,libuv-for-node)
("nghttp2" ,nghttp2 "lib")
@@ -840,7 +840,7 @@ source files.")
("icu4c" ,icu4c-67)
("libuv" ,libuv-for-node)
("llhttp" ,llhttp-bootstrap)
- ("google-brotli" ,google-brotli)
+ ("brotli" ,brotli)
("nghttp2" ,nghttp2 "lib")
("openssl" ,openssl)
("zlib" ,zlib)))))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fffbc62a20..fdd1e1e513 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6874,7 +6874,7 @@ def customize_build(EXTENSIONS, OPTIONS):
(inputs
`(("c-blosc" ,c-blosc)
("giflib" ,giflib)
- ("google-brotli" ,google-brotli)
+ ("brotli" ,brotli)
("libjpeg-turbo" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)