summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-16 19:20:39 +0100
committerMarius Bakke <marius@gnu.org>2020-12-17 00:15:49 +0100
commitc78964efa87b257991262eab0ef3ac6b719e286c (patch)
tree747aa903ffbb385582f5826855487fb3daa34896 /gnu/packages/cmake.scm
parent2add5b20323f6231f9e9fb4fd25b2c5e48828e7c (diff)
downloadguix-patches-c78964efa87b257991262eab0ef3ac6b719e286c.tar
guix-patches-c78964efa87b257991262eab0ef3ac6b719e286c.tar.gz
gnu: Remove 'curl-minimal'.
* gnu/packages/curl.scm (curl-minimal): Deprecate variable. * gnu/packages/games.scm (yamagi-quake2)[inputs]: Replace CURL-MINIMAL with CURL. * gnu/packages/cmake.scm (cmake-bootstrap)[inputs]: Likewise. (cmake-minimal)[inputs]: Don't override the "curl" input.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7316a3bf63..a68dbdd746 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -207,7 +207,7 @@
(apply invoke "./configure" configure-flags))))))
(inputs
`(("bzip2" ,bzip2)
- ("curl" ,curl-minimal)
+ ("curl" ,curl)
("expat" ,expat)
("file" ,file)
("libarchive" ,libarchive)
@@ -259,9 +259,8 @@ and workspaces that can be used in the compiler environment of your choice.")
(define preserved-files ',%preserved-third-party-files))
exp))))))
(inputs
- `(("curl" ,curl)
- ("jsoncpp" ,jsoncpp)
- ,@(alist-delete "curl" (package-inputs cmake-bootstrap))))
+ `(("jsoncpp" ,jsoncpp)
+ ,@(package-inputs cmake-bootstrap)))
(build-system cmake-build-system)
(arguments
`(#:configure-flags