summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cmake.scm7
-rw-r--r--gnu/packages/curl.scm8
-rw-r--r--gnu/packages/games.scm2
3 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7316a3bf63..a68dbdd746 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -207,7 +207,7 @@
(apply invoke "./configure" configure-flags))))))
(inputs
`(("bzip2" ,bzip2)
- ("curl" ,curl-minimal)
+ ("curl" ,curl)
("expat" ,expat)
("file" ,file)
("libarchive" ,libarchive)
@@ -259,9 +259,8 @@ and workspaces that can be used in the compiler environment of your choice.")
(define preserved-files ',%preserved-third-party-files))
exp))))))
(inputs
- `(("curl" ,curl)
- ("jsoncpp" ,jsoncpp)
- ,@(alist-delete "curl" (package-inputs cmake-bootstrap))))
+ `(("jsoncpp" ,jsoncpp)
+ ,@(package-inputs cmake-bootstrap)))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index f39dc54e4e..f9de1ebced 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -142,14 +142,8 @@ tunneling, and so on.")
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
-;; This package exists mainly to bootstrap CMake. It must not depend on
-;; anything that uses cmake-build-system.
(define-public curl-minimal
- (hidden-package
- (package/inherit
- curl
- (name "curl-minimal")
- (inputs (alist-delete "openldap" (package-inputs curl))))))
+ (deprecated-package "curl-minimal" curl))
(define-public kurly
(package
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1b7faa97c9..9109231acc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6856,7 +6856,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("curl" ,curl-minimal)
+ `(("curl" ,curl)
("libvorbis" ,libvorbis)
("mesa" ,mesa)
("openal" ,openal)