summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-02-09 16:10:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-02-09 21:00:11 +0100
commit2846aec2f7d53b9244ad55c1436437843287426a (patch)
tree4b730b380b31e19ef6f959ad0afc0c7c067da19c /gnu/packages/chicken.scm
parent13c6f9c9885092fe693ad29b0fe1e807de11a548 (diff)
downloadguix-patches-2846aec2f7d53b9244ad55c1436437843287426a.tar
guix-patches-2846aec2f7d53b9244ad55c1436437843287426a.tar.gz
gnu: chicken: Move to a separate module.
* gnu/packages/scheme.scm (chicken): Move to chicken.scm. * gnu/packages/chicken.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
new file mode 100644
index 0000000000..53631f9bd6
--- /dev/null
+++ b/gnu/packages/chicken.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages chicken)
+ #:use-module (gnu packages)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses)
+ #:select (bsd-3)))
+
+(define-public chicken
+ (package
+ (name "chicken")
+ (version "5.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://code.call-cc.org/releases/"
+ version "/chicken-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+
+ ;; No `configure' script; run "make check" after "make install" as
+ ;; prescribed by README.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check)))
+
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list "PLATFORM=linux"
+ (string-append "PREFIX=" out)
+ (string-append "VARDIR=" out "/var/lib")))
+
+ ;; Parallel builds are not supported, as noted in README.
+ #:parallel-build? #f))
+ (home-page "http://www.call-cc.org/")
+ (synopsis "R5RS Scheme implementation that compiles native code via C")
+ (description
+ "CHICKEN is a compiler for the Scheme programming language. CHICKEN
+produces portable and efficient C, supports almost all of the R5RS Scheme
+language standard, and includes many enhancements and extensions.")
+ (license bsd-3)))