summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-03-19 14:24:50 -0400
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-05 16:10:06 +0200
commit6f71fd4a5e9f2ccd0ae8b78cdb59d53e9cde9544 (patch)
tree49faaa183609027389abe3a1a237bee7a7ea0758 /gnu/packages/chez.scm
parentd8e6486877643d7d948557badc614c2b844a6d85 (diff)
downloadguix-patches-6f71fd4a5e9f2ccd0ae8b78cdb59d53e9cde9544.tar
guix-patches-6f71fd4a5e9f2ccd0ae8b78cdb59d53e9cde9544.tar.gz
gnu: chez-scheme: Update stex.
Get a patch from upstream that will help us simplify the build process for the Chez Scheme documentation. * gnu/packages/chez.scm (chez-stex): Update to commit 5405149. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 3918e7741d..b0b9abfd05 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -54,13 +54,17 @@
(file-name (git-file-name "nanopass" version)))))
(define stex
- (let ((version "1.2.2"))
+ ;; This commit includes a fix, which we would otherwise want to use as
+ ;; patch. Let's revert to tagged releases as soon as one becomes available.
+ (let* ((commit "54051494434a197772bf6ca5b4e6cf6be55f39a5")
+ (version "1.2.2")
+ (version (git-version version "1" commit)))
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/dybvig/stex")
- (commit (string-append "v" version))))
- (sha256 (base32 "1q5i8pf4cdfjsj6r2k1rih7ljbfggyxdng2p2fvsgarzihpsin2i"))
+ (commit commit)))
+ (sha256 (base32 "01jnvw8qw33gnpzwrakwhsr05h6b609lm180jnspcrb7lds2p23d"))
(file-name (git-file-name "stex" version)))))
(define-public chez-scheme