summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 15:43:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:05 +0100
commit2f1ab477729497beb5897f0e2a59e9dbb57470b1 (patch)
tree52b305d2846e8c3c7ddf2ffaa77189bcfb331c3d /gnu/packages/chez.scm
parent55623cf08adb2be38b5b4789c18f2b9ede970719 (diff)
downloadguix-patches-2f1ab477729497beb5897f0e2a59e9dbb57470b1.tar
guix-patches-2f1ab477729497beb5897f0e2a59e9dbb57470b1.tar.gz
gnu: nanopass: Don't use unstable tarball.
* gnu/packages/chez.scm (nanopass)[source]: Use GIT-FETCH and GIT-FILE-NAME. (chez-scheme)[arguments]: Adjust expected source directory name.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 863a32ce8a..5cf3231f30 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -42,12 +42,12 @@
(define nanopass
(let ((version "1.9"))
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/nanopass/nanopass-framework-scheme/archive"
- "/v" version ".tar.gz"))
- (sha256 (base32 "11pwyy4jiwhcl2am3a4ciczacjbjkyvdizqzdglb3l1hj2gj6nv2"))
- (file-name (string-append "nanopass-" version ".tar.gz")))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nanopass/nanopass-framework-scheme.git")
+ (commit (string-append "v" version))))
+ (sha256 (base32 "0lrngdna6w7v9vlp1a873hgwrwsz2p0pgkccswa4smzvdyhgfsri"))
+ (file-name (git-file-name "nanopass" version)))))
(define stex
(let ((version "1.2.1"))
@@ -142,7 +142,7 @@
(apply patch-source-shebangs (list #:source src)))
(delete-file-recursively new-name)
(invoke "mv" orig-name new-name)))
- `((,nanopass "nanopass-framework-scheme-1.9" "nanopass")
+ `((,nanopass "source" "nanopass")
(,stex "stex-1.2.1" "stex")))
;; The Makefile wants to download and compile "zlib". We patch
;; it to use the one from our 'zlib' package.