summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 15:30:10 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:05 +0100
commit55623cf08adb2be38b5b4789c18f2b9ede970719 (patch)
tree68fe61a64be5318120cc050dad29f0ee796a75b1 /gnu/packages/chez.scm
parent95b4f7ca7aa6391af10fef637c95f42c4a01debb (diff)
downloadguix-patches-55623cf08adb2be38b5b4789c18f2b9ede970719.tar
guix-patches-55623cf08adb2be38b5b4789c18f2b9ede970719.tar.gz
gnu: chez-scheme: Return #t from all phases.
* gnu/packages/chez.scm (chez-scheme)[arguments]: Always return #t from phases. Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 8476eefe12..863a32ce8a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -122,7 +122,8 @@
;; next one; see <https://github.com/cisco/ChezScheme/issues/209>.
(substitute* "csug/copyright.stex"
(("\\\\INSERTREVISIONMONTHSPACEYEAR" )
- "October 2017")))) ; tarball release date
+ "October 2017")) ; tarball release date
+ #t))
;; Adapt the custom 'configure' script.
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -140,7 +141,7 @@
(apply unpack (list #:source src))
(apply patch-source-shebangs (list #:source src)))
(delete-file-recursively new-name)
- (system* "mv" orig-name new-name)))
+ (invoke "mv" orig-name new-name)))
`((,nanopass "nanopass-framework-scheme-1.9" "nanopass")
(,stex "stex-1.2.1" "stex")))
;; The Makefile wants to download and compile "zlib". We patch
@@ -174,14 +175,14 @@
(("/bin/true") (which "true")))
(substitute* "stex/Makefile"
(("PREFIX=/usr") (string-append "PREFIX=" out)))
- (zero? (system* "./configure" "--threads"
- (string-append "--installprefix=" out))))))
+ (invoke "./configure" "--threads"
+ (string-append "--installprefix=" out)))))
;; Installation of the documentation requires a running "chez".
(add-after 'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((doc (string-append (assoc-ref outputs "doc")
"/share/doc/" ,name "-" ,version)))
- (system* "make" "docs")
+ (invoke "make" "docs")
(with-directory-excursion "csug"
(substitute* "Makefile"
;; The ‘installdir=’ can't be overruled on the command line.
@@ -191,7 +192,7 @@
;; Avoid the whole mess by running the (machine-independent)
;; ‘installsh’ script at its original location.
(("\\$m/installsh") "makefiles/installsh"))
- (system* "make" "install")
+ (invoke "make" "install")
(install-file "csug.pdf" doc))
(with-directory-excursion "release_notes"
(install-file "release_notes.pdf" doc))