summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:47:45 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commitddab5244dfa85e5ad73da80c3169fe790387743b (patch)
tree2aaf4f58f4398c60278cbb16dba9b1108f27e36a /gnu/packages/c.scm
parent4c66a8deb5f51fd4f944fb62c43aa1e2a477711c (diff)
downloadguix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar
guix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar.gz
gnu: Add aws-c-event-stream.
* gnu/packages/c.scm (aws-c-event-stream): New variable. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index bb3d90e1cd..2ea9c2ac51 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -584,3 +584,30 @@ portability.")
with fallback to efficient C99 software implementations.")
(home-page "https://github.com/awslabs/aws-checksums")
(license license:asl2.0)))
+
+(define-public aws-c-event-stream
+ (package
+ (name "aws-c-event-stream")
+ (version "0.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vl9ainc4klv0g9gk1iv4833bsllni6jxn6mwb0fnv2dnlz7zv9q"))
+ (patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("aws-c-common" ,aws-c-common)))
+ (inputs
+ `(("aws-checksums" ,aws-checksums)))
+ (synopsis "Amazon Web Services client-server message format library")
+ (description
+ "This library is a C99 implementation for @acronym{AWS,Amazon Web Services}
+event stream encoding, a binary format for bidirectional client-server
+communication.")
+ (home-page "https://github.com/awslabs/aws-c-event-stream")
+ (license license:asl2.0)))