summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:41:08 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commit4c66a8deb5f51fd4f944fb62c43aa1e2a477711c (patch)
tree7be4542b6501a0d2cbc006b98f1b75c727fd0a72 /gnu/packages/c.scm
parent5f998a5cdbbb3034c3948b3e73cc90b656ef8431 (diff)
downloadguix-patches-4c66a8deb5f51fd4f944fb62c43aa1e2a477711c.tar
guix-patches-4c66a8deb5f51fd4f944fb62c43aa1e2a477711c.tar.gz
gnu: Add aws-checksums.
* gnu/packages/c.scm (aws-checksums): New variable. * gnu/packages/patches/aws-checksums-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 628e8c0dad..bb3d90e1cd 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -36,6 +36,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
+ #:use-module (gnu packages)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
@@ -559,3 +560,27 @@ portability.")
structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")
(home-page "https://github.com/awslabs/aws-c-common")
(license license:asl2.0)))
+
+(define-public aws-checksums
+ (package
+ (name "aws-checksums")
+ (version "0.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f9scl5734pgjlsixspwljrrlndzhllwlfygdcr1gx5p0za08zjb"))
+ (patches (search-patches "aws-checksums-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("aws-c-common" ,aws-c-common)))
+ (synopsis "Amazon Web Services checksum library")
+ (description
+ "This library provides cross-Platform hardware accelerated CRC32c and CRC32
+with fallback to efficient C99 software implementations.")
+ (home-page "https://github.com/awslabs/aws-checksums")
+ (license license:asl2.0)))