summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:02:11 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commitb3c1c37d743f55c716727a3efe9067654b9687f5 (patch)
tree14c5f9885fd07eaf0a48d93ae45e45c2ae0155ab /gnu/packages/c.scm
parent1f1bb634c321b26b424c58e1fcdd21703b58f171 (diff)
downloadguix-patches-b3c1c37d743f55c716727a3efe9067654b9687f5.tar
guix-patches-b3c1c37d743f55c716727a3efe9067654b9687f5.tar.gz
gnu: Add aws-c-s3.
* gnu/packages/c.scm (aws-c-s3): New variable. * gnu/packages/patches/aws-c-s3-cmake-prefix.patch, gnu/packages/patches/aws-c-s3-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index f2ea6ccda4..cd31c97285 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -803,3 +803,34 @@ currently limited to Huffman encoding and decoding.")
authentication.")
(home-page "https://github.com/awslabs/aws-c-auth")
(license license:asl2.0)))
+
+(define-public aws-c-s3
+ (package
+ (name "aws-c-s3")
+ (version "0.1.19")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vkjd8dh99d8qsl7irnbkcdf9vjmcznx0jz186la0472z4h48wjj"))
+ (patches
+ (search-patches
+ "aws-c-s3-cmake-prefix.patch"
+ "aws-c-s3-disable-networking-tests.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-auth" ,aws-c-auth)
+ ("aws-c-http" ,aws-c-http)))
+ (synopsis "Amazon Web Services client library for Amazon S3")
+ (description
+ "This library provides a C99 client implementation of the Simple Storage
+Service (S3) protocol for object storage.")
+ (home-page "https://github.com/awslabs/aws-c-s3")
+ (license license:asl2.0)))