summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:00:27 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commit1f1bb634c321b26b424c58e1fcdd21703b58f171 (patch)
tree806bc0247dbfb9c0e1a5be8140640d2bfdc59974 /gnu/packages/c.scm
parent2069238cb35fee5f8da1dd8fab6df4749bee135b (diff)
downloadguix-patches-1f1bb634c321b26b424c58e1fcdd21703b58f171.tar
guix-patches-1f1bb634c321b26b424c58e1fcdd21703b58f171.tar.gz
gnu: Add aws-c-auth.
* gnu/packages/c.scm (aws-c-auth): New variable. * gnu/packages/patches/aws-c-auth-cmake-prefix.patch, gnu/packages/patches/aws-c-auth-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 8e0f97881c..f2ea6ccda4 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -770,3 +770,36 @@ specifications.")
currently limited to Huffman encoding and decoding.")
(home-page "https://github.com/awslabs/aws-c-compression")
(license license:asl2.0)))
+
+(define-public aws-c-auth
+ (package
+ (name "aws-c-auth")
+ (version "0.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yh9s6q3ahq39xgvihp2a5cn9h39qlq8wfjc32m0ayi9x739rbqg"))
+ (patches
+ (search-patches
+ "aws-c-auth-cmake-prefix.patch"
+ "aws-c-auth-disable-networking-tests.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-cal" ,aws-c-cal)
+ ("aws-c-common" ,aws-c-common)
+ ("aws-c-http" ,aws-c-http)
+ ("aws-c-io" ,aws-c-io)))
+ (synopsis "Amazon Web Services client-side authentication library")
+ (description
+ "This library provides a C99 implementation for AWS client-side
+authentication.")
+ (home-page "https://github.com/awslabs/aws-c-auth")
+ (license license:asl2.0)))