summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:03:28 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commit5f998a5cdbbb3034c3948b3e73cc90b656ef8431 (patch)
tree9529350588c468a70379ab967f2a15b078ae0320 /gnu/packages/c.scm
parent785a0f72936ac486dafd022dfffb8247ebea190f (diff)
downloadguix-patches-5f998a5cdbbb3034c3948b3e73cc90b656ef8431.tar
guix-patches-5f998a5cdbbb3034c3948b3e73cc90b656ef8431.tar.gz
gnu: Add aws-c-common.
* gnu/packages/c.scm (aws-c-common): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 7a7408b4d7..628e8c0dad 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages bootstrap)
@@ -536,3 +538,24 @@ avoiding distractions when studying code that uses @code{#ifdef} heavily for
portability.")
(license (list license:bsd-2 ;all files except...
license:bsd-3)))) ;...the unidef.1 manual page
+
+(define-public aws-c-common
+ (package
+ (name "aws-c-common")
+ (version "0.4.63")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16bc6fn1gq3nqcrzgpi2kjphq7xkkr73aljakrg89ysm6hyzyim9"))))
+ (build-system cmake-build-system)
+ (synopsis "Amazon Web Services core C library")
+ (description
+ "This library provides common C99 primitives, configuration, data
+ structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")
+ (home-page "https://github.com/awslabs/aws-c-common")
+ (license license:asl2.0)))